Temporary connection issues
Incident Report for ChargeDesk
Resolved
This incident has been resolved.
Posted almost 2 years ago. Mar 21, 2016 - 01:23 AEDT
Monitoring
We are currently seeing a spike in connectivity problems to ChargeDesk. We are monitoring this issue and will make this issue as resolved once the problem is rectified.
Posted almost 2 years ago. Mar 20, 2016 - 23:06 AEDT