Connectivity issues
Incident Report for ChargeDesk
Resolved
This issue is now resolved.

A temporary network issue was degrading access for our hosting provider.

Please email contact@chargedesk.com if you have any further questions.
Posted over 2 years ago. Apr 26, 2015 - 19:04 AEST
Investigating
We've been alerted to some intermittent connectivity issues which is degrading speed for some customers.

We are currently investigating.
Posted over 2 years ago. Apr 26, 2015 - 18:59 AEST